Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 05, 2025 - 21:00 CDT
Scheduled
Mailjet will be conducting scheduled infrastructure maintenance on Saturday, July 5th from 9:00 PM to 1:00 AM CDT.
During this window, all MOVEit Cloud customers may experience brief interruptions or delays in email sending as Mailjet works to enhance system performance and stability.
We appreciate your understanding and will ensure email services are restored as quickly as possible.
Posted Jun 25, 2025 - 13:27 CDT
This scheduled maintenance affected: NCR MOVEit Cloud and Mailjet Outgoing SMTP.